This section describes several common failures that you may encountered when transmitting advance data to Comdata through the Comdata Advance/Payment Processing screen. The Error descriptions in the tables below link to what shows within the Result column within Comdata Advance/Payment Processing. NOTE: You can hover the mouse over the error description within the Result column to view the entire message.
Figure 25: Comdata Advance/Payment Processing screen with error
Error Listing
Error: |
CALL 18007413030 (Comdata code 153) |
Cause: |
Incorrect Card Number set for the employee within the Advance User Account information within their Personnel Setup record. |
Resolution: |
For the employee associated to the advance being transmitted, verify that the Card Number set within the Comdata Advance User Account section within their Personnel Setup record is correct. Refer to Step 6 within Comdata Integration Setup. |
Error: |
CARD-EMPL# WRONG VERIFY AND RETRY (Comdata code 173) |
Cause: |
Incorrect Account Number set for the employee within the Advance User Account information within their Personnel Setup record. |
Resolution: |
For the employee associated to the advance being transmitted, verify that the Account Number set within the Comdata Advance User Account section within their Personnel Setup record is correct. Refer to Step 6 within Comdata Integration Setup. |
Error: |
Exception: ComData Username not found. The Comdata XML System must have a "Username" XML System Option set up in Administration. |
Cause: |
Blank or whitespace for the Username assigned within XML System Setup. |
Resolution: |
Verify the XML System Option of Username within the XML System Setup for Comdata is defined with the correct value. Refer to Step 3 within Comdata Integration Setup. |
Error: |
Exception: ComData Password not found. The Comdata XML System must have a "Password" XML System Option set up in Administration. |
Cause: |
Blank or whitespace for the Password assigned within XML System Setup. |
Resolution: |
Verify the XML System Option of Password within the XML System Setup for Comdata is defined with the correct value. Refer to Step 3 within Comdata Integration Setup. |
Error: |
Exception: ComData WebServiceURL not found. The Comdata XML System must have a "WebServiceURL” XML System Option set up in Administration. |
Cause: |
Blank or whitespace for the WebServiceURL assigned within XML System Setup. |
Resolution: |
Verify the XML System Option of WebServiceURL within the XML System Setup for Comdata is defined with the correct value. Refer to Step 3 within Comdata Integration Setup. |
Error: |
Exception: com.ibm.wsspi.wssecurity.SoapSecurityException: WSEC6510E: Failed to login: com.ibm.websphere.security.auth.WSLoginFailedException: No user AAA found. |
Cause: |
Invalid Username set within XML System Setup. |
Resolution: |
The username ‘AAA’ from the error is not valid within Comdata. Verify the XML System Option of Username within the XML System Setup for Comdata is defined with the correct value. Refer to Step 3 within Comdata Integration Setup. |
Error: |
Exception: com.ibm.wsspi.wssecurity.SoapSecurityException: WSEC6510E: Failed to login: com.ibm.websphere.security.auth.WSLoginFailedException: javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090400, comment: AcceptSecurityContext error, data 52e, v1db1☐] |
Cause: |
Invalid Password set within XML System Setup. |
Resolution: |
The Password associated to the Comdata XML System record is invalid. Verify the XML System Option of Password within the XML System Setup for Comdata is defined with the correct value. Refer to Step 3 within Comdata Integration Setup. |
Error: |
INVALID SIGNON. 99972 (Comdata code 99972) |
Cause: |
Incorrect Username and/or Password within the Comdata Advance Banking Provider Setup record. |
Resolution: |
Verify that the Username and Password are correct for the Comdata record established within the Advance Banking Provider Setup. Refer to Step 4 within Comdata Integration Setup. |
Error: |
SYSTEM ERROR, CDREPRT. 99970 (Comdata code 99970) |
Cause: |
Incorrect Account ID set for the employee within the Advance User Account information within their Personnel Setup record. |
Resolution: |
For the employee associated to the advance being transmitted, verify that the Account ID set within the Comdata Advance User Account section within their Personnel Setup record is correct. Refer to Step 6 within Comdata Integration Setup. |